Troubleshooting

This page details some common issues and their respective workarounds. For Anaconda installation or technical support options, visit our support offerings page.


403 error

Problem

A 403 error is a generic Forbidden error issued by a web server in the event the client is forbidden from accessing a resource. The 403 error you are receiving may look like the following:

* Collecting package metadata (current_repodata.json): failed
* UnavailableInvalidChannel: The channel is not accessible or is invalid.
    * channel name: pkgs/main
    * channel url: https://repo.anaconda.com/pkgs/main
    * error code: 403

    * You will need to adjust your conda configuration to proceed.
    * Use `conda config --show channels` to view your configuration's current state, and use `conda config --show-sources` to view config file locations.
There are several reasons a 403 error could be received:
  • The user has misconfigured their channels in their configuration (for example, the secure location where the token is stored was accidentally deleted (most common)

  • A firewall or other security device or system is preventing user access (second most common)

  • We are blocking their access because of a potential terms of service violation (third most common)

Solution

  1. First, run the following to undo your configuration of Commercial Edition::

    conda config –remove-key default_channels

  2. Next, install or upgrade the conda-token tool::

    conda install –freeze-installed conda-token

  3. Lastly, re-apply the token and configuration settings::

    # Replace <TOKEN> with your token conda token set <TOKEN>

If this doesn’t resolve the issue, we recommend consulting our Terms of Service error page.

Conda: Channel is unavailable/missing or package itself is missing

Problem

After you have configured your .condarc for either Team Edition or Commercial Edition, in some cases you may be unable to install packages. You may receive an error message that the channel or package is unavailable or missing.

Solution

One potential fix for all of these is to run the following command:

conda clean -i

This will clear the “index cache” and force conda to sync metadata from the repo server.

Using Redis

Cause

By default, Redis does not require a password. Not enabling a password requirement leaves your instance of Team Edition vulnerable.

Solution

Follow these steps to password protect your instance:

  1. In the installation directory, update config/nginx/conf.d/repo.conf to include the add_header directive somewhere in the server block:

    server {
        ...
        add_header Strict-Transport-Security "max-age=31536000; includeSubDomains" always;
        ...
    }
    
  2. Create a directory called redis in the configs directory:

    mkdir -p config/redis
    
  3. Create a file called redis.conf inside config/redis with the following contents:

    requirepass "mypassword"
    
  4. Update the docker-compose.yml file of TE installation to mount this custom redis config:

    redis:
        image: ${DOCKER_REGISTRY}redis-ubi:${VERSION}
        restart: always
        volumes:
          - ${BASE_INSTALL_DIR}/config/redis/redis.conf:/usr/local/etc/redis/redis.conf
        command:
        - /usr/local/etc/redis/redis.conf
    
    #Alternative:
    #  redis:
    #    image: ${DOCKER_REGISTRY}redis-ubi8:${VERSION}
    #    restart: always
    #    ports:
    #    - 6379:6379
    #    command:
    #    - /usr/local/bin/redis-server
    #    - --requirepass mypassword
    # If you use this alternative configuration, there's no need to create a config/redis/redis.conf file to mount in.
    
  5. Update REDIS_ADDR variable in .env file to include password:

    ...
    REDIS_ADDR=redis://:mypassword@redis:6379/0
    ...
    
  6. Restart docker-compose services so changes are picked up. You can do this using:

    docker-compose up -d